Page 1 of 1

Gauges stopped working after updating RR

Posted: Thu May 11, 2023 11:08 pm
by AstrosFanHou
2007 Mazdaspeed 3

Firmwares tested:
ADS-RR(SR)-MA1-DS (512) v1.4
ADS-RR(SR)-MA1-DS (512) v1.2

Last firmware that worked:

Gauges worked before I updated. They show up but I get no readings. They all just have a dash in the place of where the reading should be.

Steering controls still work.

Also this time when I updated it said I needed the HRMA1 but last time I didn’t need it. Why is there no option to update without having to select that harness in your setup? Does it matter that I selected it and just used my current wiring that worked before this harness was even available?

Can someone make it so I can download and install the last firmware that worked for me (ADS-RR(SI)-MAZO1-DS v2.50) so I can eliminate the chance that it’s the firmware?

Re: Gauges stopped working after updating RR

Posted: Fri May 12, 2023 9:16 pm
by AstrosFanHou

I called tech support and they directed me to chose my year and make but instead of picking the 3 as your model pick one of the options without a model name or picture of a car. I believe it said “MAZO1-DS” instead of a model of a car. I chose it and it took me to the correct firmware to use without the HRMA1. I’m now on ADS-RR(SI)-MAZO1-DS v2.6 and my gauges work again. Hopefully this helps someone in the future that may want to update their RR with without having buy the HRMA1 and having to rewire everything.

Thank you tech support for your help. Everyone have a good weekend.