MUS1 Dash Kit button issue

Group using the FO1 and FO2 firmware for Ford SYNC retention * see specific firmware for full feature list.
Post Reply
Fried Rice
New User
Posts: 7
Joined: Wed Jun 28, 2017 9:11 pm

MUS1 Dash Kit button issue

Post by Fried Rice »

I’ve had the MUS1 dash kit installed for about a year and have recently developed a strange problem with the programmable buttons.
When I originally programmed the kit, I set the buttons up from left to right as follows:

Climate, Fan Speed -, Max AC, Fan Speed +, Defrost.

Recently, the buttons seem to have “translated right.” When I press Climate, the fan speed goes down, when I press Fan Speed Down, the Max AC toggles, etc. The Defrost does not to anything.

The buttons worked properly when installed, and I have not reprogrammed the MRR or updated firmware in the radio since the original installation.

What would cause this? A failing button pad or wiring harness?

User avatar
ADS Team
Posts: 870
Joined: Mon Jan 15, 2018 2:18 pm

Re: MUS1 Dash Kit button issue

Post by JustinFerroni »

That is a bit of an oddity there. Have you tried resetting the module yet? This can be done by accessing the maestro menus in the radios setting page and perform a Master Module Reset. If this fails to correct the issue you are experiencing i would they reflash with the current live firmware and test again.
Justin Ferroni
Technical Support Specialist
ADS Maestro
T 514.807.2888
New User
Posts: 1
Joined: Fri Aug 27, 2021 9:41 pm

Re: MUS1 Dash Kit button issue

Post by HFChimp »

FYI - Master Module Reset failed to resolve for me. I pulled the Maestro out and reflashed it to previous configuration and the problem is SOLVED!

Thanks Justin
Last edited by HFChimp on Mon May 29, 2023 9:24 pm, edited 1 time in total.
Post Reply

Return to “Ford, Lincoln, Mercury, Mazda”