Subaru Forester 09-13 wiring, SWC, Amp power and Reverse wire

Post Reply
swansong
New User
Posts: 2
Joined: Sun Dec 24, 2017 1:37 am

Subaru Forester 09-13 wiring, SWC, Amp power and Reverse wire

Post by swansong » Sun Dec 24, 2017 3:26 am

Hi,

I have a 2012 Forester X Premium bluetooth non-nav, and am installing an aftermarket Kenwood DDX794 touchscreen unit with the Maestro RR and SU1 T-harness. I have flashed the Maestro and connected the head unit wires and SU1 harness power, ground, acc, illum wires, but I am extremely confused about the steering wire, amp/antenna turn-on and reverse wires. I hope you can please clarify the correct hookup since the diagram is rather vague and doesn't seem to be exactly plug and play... please correct me if I'm overthinking this!

1) Steering Wheel Controls
My Kenwood has a blue-yellow striped wire on the input plug but am unclear what to connect it to. Included with the RR is a 4-pin blue plug that terminates in a 3.5mm plug and a blue-yellow striped wire, do I connect this to the Kenwood blue-yellow striped wire (and what about the 3.5mm plug)? There is also a blue-yellow striped wire on the SU1 wiring but it seems to connect to harness C for powering the camera, which I don't need as I am installing an aftermarket camera. What is most confusing is the factory harness pin 4 is supposed to be the S.R1+ steering remote wire but this seems to be connected to SU1 via the C camera harness... I don't understand???

2) Amp and antenna power
The Kenwood outputs 12V 350ma on the P.Cont/Antenna wire for amp turn-on, so I will connect this to my power amp and parking brake bypass. On the SU1 harness there is a blue-white amp wire which goes to the sub out white 2-pin plug which I can ignore since I'm splicing my amp turn-on directly to the Kenwood wire. Strangely there is a separate SU1 solid blue wire which connects to pin 19, NC/12V+ power, but there is no SU1 pin that connects to "Antenna On" which is pin 9 on the factory harness. Therefore to power my antenna booster should I cut and splice factory harness wire #9 to the Kenwood 12v Amp/P. Cont. wire as well, or connect wire #9 to the blue 12V SU1 wire on pin 19? I don't want to fry the Kenwood or the antenna booster by connecting two 12V sources inadvertently. It's unclear what is the role of the solid blue wire.

3) Reverse wire
There is a white/purple wire on the SU1 harness but I don't see where it leads, it doesn't seem to connect anywhere to the factory harness. My guesses for hooking up are labeled a-d.
a) The SU1 includes two black and red 2-pin plugs, that terminate in an OBDII plug and a purple-white striped wire marked "Rev in Man Trans," respectively. Should the latter "Rev in Man Trans" wire connect to the Kenwood purple-white wire? Then what connects to the car's actual reverse signal?
b) I researched that the factory harness 16-pin J602 factory plug has a 12V Reverse (RVS) wire on pin 16, should I cut and splice this wire to the Kenwood purple-white and the SU1 purple-white wire?
c) Or is it ok to leave out the SU1 purple-white wire and just connect the Kenwood 12V reverse purple-white wire, backup camera power wire, and the factory J602 pin 16 without hooking up to the maestro?
d) Or just tap the 12V reverse light wire in the rear lights, and run that power to the rear camera and to the Kenwood purple-white wire directly, with or without the Maestro/SU1 purple-white wire? Does the maestro really need to know when the car is in reverse, since the Kenwood head unit is the one displaying the video anyway?

4) 3-pin 3.5mm plug from Maestro RR into the Kenwood iDatalink "I/F" jack?
Is this carrying the SWC signal, the manual says it's for audio but I don't understand why...? I couldn't find any info on an "I/F" jack but the SU1 instructions say to plug the 3.5mm plug into the radio here, please confirm.

Thank you for reading my questions, hope you can help answer for me and others who can't make sense of this.

-swansong

User avatar
Dara DeGrand
ADS Team
Posts: 5014
Joined: Mon Dec 02, 2013 1:34 pm

Re: Subaru Forester 09-13 wiring, SWC, Amp power and Reverse wire

Post by Dara DeGrand » Tue Dec 26, 2017 8:53 am

1) This wire isn't mentioned on your diagram because it doesn't need to be hooked up.

2) The solid blue wire is a power antenna. It could be pinned in multiple places if we have seen vehicles with that wire pinned in different places.

3) I have seen your post asking about the reverse wires in the other thread and replied to it. If you have further questions about the reverse wire, just let me know.

4) That's for your OEM audio, if we retain something for you like your OEM satellite radio. Most subaru vehicles don't have a use for this wire.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “SU1 radio replacement solution”