Connectors dont match - Scion TC 07

Post Reply
PakoDaMonzta
New User
Posts: 3
Joined: Sun Sep 11, 2016 10:06 pm

Connectors dont match - Scion TC 07

Post by PakoDaMonzta » Sun Sep 11, 2016 10:15 pm

hey guys, i purchased, iDatalink HRN-RR-T01 Factory Integration and iDatalink Maestro ADS-MRR Factory Integration Adapter to connect my Kenwood DDX9703S to my Scion tC 07, but when i tried to connect TO1 harness to my car some of the plugs of the car wont fit TO1 harness. i bought these two products because it said it was compatible with my car and stereo... Som question is, I got a wrong harness, or i need to do something else in order to get it connected?

User avatar
Dara DeGrand
ADS Team
Posts: 5145
Joined: Mon Dec 02, 2013 1:34 pm

Re: Connectors dont match - Scion TC 07

Post by Dara DeGrand » Mon Sep 12, 2016 9:16 am

You won't use all of the connectors. At the very least, you should have the main two plugs (numbers 1 and 2) and the 20 pin connector (#4, if you have steering wheel controls). The OBD2 plug is universal, so that should fit as well.
You do not have the required permissions to view the files attached to this post.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

PakoDaMonzta
New User
Posts: 3
Joined: Sun Sep 11, 2016 10:06 pm

Re: Connectors dont match - Scion TC 07

Post by PakoDaMonzta » Mon Sep 12, 2016 10:08 am

Dara DeGrand wrote:You won't use all of the connectors. At the very least, you should have the main two plugs (numbers 1 and 2) and the 20 pin connector (#4, if you have steering wheel controls). The OBD2 plug is universal, so that should fit as well.

So, basically i only need three of the connectors from my car? Because thats the total i can connect to the TO1 harness, 1-2 and 3? But when i connect them, my stereo (Kenwood DDX9703S) wont turn on, theres only a lil red light blinking but it wont turn on nomatter what i push. I double check the harness stereo connection to TO1 harness and everything seems right, i didnt connect parking brake cable, antena, amplificator.

The 16 pin female adapter from my car wont connect to any of the TO1 harness, so thats not a problem at all? Image

User avatar
Dara DeGrand
ADS Team
Posts: 5145
Joined: Mon Dec 02, 2013 1:34 pm

Re: Connectors dont match - Scion TC 07

Post by Dara DeGrand » Mon Sep 12, 2016 11:18 am

How many red flashes are you getting? Two fast, or one slow?

The 16 pin is not needed. Plug #1 is responsible for making the radio turn on and off.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

PakoDaMonzta
New User
Posts: 3
Joined: Sun Sep 11, 2016 10:06 pm

Re: Connectors dont match - Scion TC 07

Post by PakoDaMonzta » Mon Sep 12, 2016 11:39 am

Dara DeGrand wrote:How many red flashes are you getting? Two fast, or one slow?

The 16 pin is not needed. Plug #1 is responsible for making the radio turn on and off.
Red light blinks l fast, every 5-10 sec, i think... I contact kenwood, and told me to check voltage coming from the yellow wire. That it had to be 12V, and if its not, thats the reason it might not turn on. Ill do that, once i get home, and keep you guys updated.

User avatar
Dara DeGrand
ADS Team
Posts: 5145
Joined: Mon Dec 02, 2013 1:34 pm

Re: Connectors dont match - Scion TC 07

Post by Dara DeGrand » Mon Sep 12, 2016 2:08 pm

We only have two flash patterns- once or twice red. If you can, give us a call when the car is pulled apart and we can troubleshoot it.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

jmanh2c
New User
Posts: 4
Joined: Sun Oct 02, 2016 1:09 am

Re: Connectors dont match - Scion TC 07

Post by jmanh2c » Sun Oct 02, 2016 12:00 pm

Original Poster, or anyone else reading. I was wondering if you were able to obtain climate controls on your stereo with the use of the TO1 and the iDatalink Maestro? I already ordered both but that's the one thing I'm curious about. And if so if you maintain the controls with the original climate controls as well. Any info would be nice. Scion tC 07.

User avatar
Dara DeGrand
ADS Team
Posts: 5145
Joined: Mon Dec 02, 2013 1:34 pm

Re: Connectors dont match - Scion TC 07

Post by Dara DeGrand » Mon Oct 03, 2016 9:43 am

We do not do on-screen climate controls in that vehicle.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

jmanh2c
New User
Posts: 4
Joined: Sun Oct 02, 2016 1:09 am

Re: Connectors dont match - Scion TC 07

Post by jmanh2c » Wed Oct 05, 2016 2:56 pm

I received my Maestro RR and my TO1 harness today. Connected all the wires to the after market harness(kenwood). Connected all the cables to the Maestro. Turned key to ACC and HU will not turn on. I checked fuse in the back of my HU (DNX690HD) and the fuses for the car and they are all good. I rechecked the wire connected on the harness and everything looks secure. Is there anything I'm missing or any specific order of connections I may have missed? Car: 2007 Scion tC . HU: DNX690HD. Maestro RR with TO1 Harness. Thank you for any help.

User avatar
Dara DeGrand
ADS Team
Posts: 5145
Joined: Mon Dec 02, 2013 1:34 pm

Re: Connectors dont match - Scion TC 07

Post by Dara DeGrand » Wed Oct 05, 2016 3:55 pm

I sent a different version of the firmware to your account- To flash this firmware, log in, hit "flash your module", then select the "flash by user firmware" tab. There will be a firmware waiting for you in that section: ADS-RR(SR)-TOY01-DS (512) 1.6. Select it, and proceed with your flash. That should take care of it.

Thanks,
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

jmanh2c
New User
Posts: 4
Joined: Sun Oct 02, 2016 1:09 am

Re: Connectors dont match - Scion TC 07

Post by jmanh2c » Wed Oct 05, 2016 8:51 pm

Thank you you beautiful woman you! I flashed the new firmware to the Maestro RR module and its working great now! I'm assuming its not compatible but figured I would check, Vehicle info doesn't register when I open a door. I treid with car on or off or even while driving. (I was driving slow in a secluded area). Thank you again for the Firmware, made my day when it all came together.

User avatar
Dara DeGrand
ADS Team
Posts: 5145
Joined: Mon Dec 02, 2013 1:34 pm

Re: Connectors dont match - Scion TC 07

Post by Dara DeGrand » Thu Oct 06, 2016 8:28 am

You're welcome! The TC can't show door trigger status because it doesn't have a BCM; the door trigger status is not found on any data networks, so we don't have a way to see it.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

User avatar
StatusChecka
New User
Posts: 6
Joined: Fri Sep 29, 2017 1:34 pm

Re: Connectors dont match - Scion TC 07

Post by StatusChecka » Fri Sep 29, 2017 1:51 pm

Dara DeGrand wrote:
Mon Sep 12, 2016 9:16 am
You won't use all of the connectors. At the very least, you should have the main two plugs (numbers 1 and 2) and the 20 pin connector (#4, if you have steering wheel controls). The OBD2 plug is universal, so that should fit as well.
This is the second old thread I re-opened, please let me know the etiquette. If you see this post, would you mind uploading your attachment again? I think the link is dead. I'd like to know which plugs this individual should be using on his RR, as my vehicle is similar. 2013 Scion tC.

User avatar
Dara DeGrand
ADS Team
Posts: 5145
Joined: Mon Dec 02, 2013 1:34 pm

Re: Connectors dont match - Scion TC 07

Post by Dara DeGrand » Fri Sep 29, 2017 2:36 pm

We migrated all posts to a new server, so the attachment probably got lost.

See attached. You'll use the main TO1 connector, the 20-pin steering wheel control cable, and the OBD2 plug (if you're using an iDatalink compatible radio).
TO1.jpg
You do not have the required permissions to view the files attached to this post.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “TO1 radio replacement solution”