2014 FJ Cruiser TO1 Harness

Group using the TO1 and TO2 firmware * see specific firmware for full feature list.
Post Reply
Stlmco
New User
Posts: 5
Joined: Sun May 20, 2018 4:23 pm

2014 FJ Cruiser TO1 Harness

Post by Stlmco » Sun May 20, 2018 4:56 pm

One of the four plugs on the TO1 harnes does not plug into the plugs I disconnected from the back of the radio.
It is the 6 pin connector with purple (x2), green (x2) and blue wires. Looks like it should have an adapter just like the 10 pin plug, though unlike the 10 pin plug the instructions do not show any adapter. The instructions do clearly show where all four plugs are to be connected to the vehicle.

Also, the OEM radio had a square blue plug (satellite radio antenna ?). My Pioneer MVH-2300 NEX does not have any place to plug this in. Is this not needed with the Maestro?

User avatar
Dara DeGrand
ADS Team
Posts: 4802
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2014 FJ Cruiser TO1 Harness

Post by Dara DeGrand » Mon May 21, 2018 8:50 am

That is normal- there are so many toyotas covered under this harness that we have a lot of plugs on it, and you won't need every one. The ones you're mentioning aren't anything that you need for the new radio to function, so no need to worry.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Stlmco
New User
Posts: 5
Joined: Sun May 20, 2018 4:23 pm

Re: 2014 FJ Cruiser TO1 Harness

Post by Stlmco » Tue May 22, 2018 6:53 am

Looking at a wiring diagram for the OEM JBL radio, determined that the fourth plug is for the OEM mic. Does the Maestro RR not support the OEM mic? If not, is there an adapter that will allow the OEM mic to be plugged into the mic plug on my aftermarket radio (Pioneer MVH-2300NEX)? It would appear from the wiring diagram that the OEM mic is powered.

User avatar
Dara DeGrand
ADS Team
Posts: 4802
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2014 FJ Cruiser TO1 Harness

Post by Dara DeGrand » Tue May 22, 2018 8:42 am

We are not able to support the OEM bluetooth system (including the mic) in this application. You must use the Pioneer microphone.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Stlmco
New User
Posts: 5
Joined: Sun May 20, 2018 4:23 pm

Re: 2014 FJ Cruiser TO1 Harness

Post by Stlmco » Tue May 22, 2018 6:30 pm

Thanks. Next question... I can play music using the OEM usb plug, but can not access Apple CarPlay. It only works if I plug directly into the usb plug on the back of the radio. Is this correct, or should CarPlay work using the OEM usb plug routed through the Maestro RR?

User avatar
Dara DeGrand
ADS Team
Posts: 4802
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2014 FJ Cruiser TO1 Harness

Post by Dara DeGrand » Wed May 23, 2018 8:31 am

CarPlay will not work using the OEM USB. We don't have a way to properly re-route the signal from the factory usb module to the USB input of the radio. Because of that (and the fact that CarPlay is a Pioneer feature), you need to directly plug into the Pioneer's USB, so that it can get the signal to make CarPlay work.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Stlmco
New User
Posts: 5
Joined: Sun May 20, 2018 4:23 pm

Re: 2014 FJ Cruiser TO1 Harness

Post by Stlmco » Sat May 26, 2018 5:47 pm

Got everything hooked up and it all works great, except...

The radio does not recognize when the parking brake is engage. I double checked the wiring and everything is correct. LtGrn to LtGrn. What is strange is that the yellow/black wire for the foot brake is not connected to the radio, but the radio correctly sees when I apply to foot brake. I assume this must be a data signal the radio sees.

I did check the wiring with a multimeter. When I step on the foot brake the yellow/black wire (not connected to the radio) sees power. But, when I set the parking brake the light green wire does not see any voltage.

It would appear that the Maestro unit is not correctly passing the parking brake engaged signal through to the radio.

Stlmco
New User
Posts: 5
Joined: Sun May 20, 2018 4:23 pm

Re: 2014 FJ Cruiser TO1 Harness

Post by Stlmco » Sat May 26, 2018 6:37 pm

Also, the “Set Tire Position” screen is not an option when I access the settings screen from the Vehicle Information screen. How do I change position of the TPMs?

User avatar
Dara DeGrand
ADS Team
Posts: 4802
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2014 FJ Cruiser TO1 Harness

Post by Dara DeGrand » Mon May 28, 2018 8:37 am

The FJ Cruiser does not have a BCM, so certain signals that you would normally see on the data lines are not present on this vehicle (parking brake, door triggers, etc.) In this vehicle, you would need to run your parking brake to the p. brake wire in the vehicle.

As for the tire location, you should be able to access it by pressing the settings icon on the vehicle info screen.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “Toyota”