Kenwood DMX7704s Stuck in Rear View

Group using the TO1 and TO2 firmware * see specific firmware for full feature list.
Post Reply
mark60
New User
Posts: 8
Joined: Sat Apr 07, 2018 7:53 pm

Kenwood DMX7704s Stuck in Rear View

Post by mark60 » Sat Apr 07, 2018 7:59 pm

Installed today in a 2015 Toyota Rav4 without factory JBL. Everything works as it should except for the factory backup cam. It comes on when shift into reverse but then stays on. I too can switch it with the headunit buttons and go to any other screen but it won't leave rear view on it's own. I have the TO2 harness and the TOY02-DS firmware. I've reflashed and the problem persists.

User avatar
Dara DeGrand
ADS Team
Posts: 5144
Joined: Mon Dec 02, 2013 1:34 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by Dara DeGrand » Mon Apr 09, 2018 9:14 am

If you have access to a meter, meter the voltage on the purple/white wire. It should only have 12 volts on it when you are in reverse. If that is how it's working and the Kenwood isn't following that, it's a Kenwood firmware bug.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

mark60
New User
Posts: 8
Joined: Sat Apr 07, 2018 7:53 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by mark60 » Tue Apr 10, 2018 5:45 pm

Thank You Dara. It actually started working on it's own but my wife just told me it's intermittent. Sometimes it stays in rear view and sometimes it doesn't. One other curious thing was that the only way I could get the voice control button on the steering wheel working was to use the harness with the blue plug. I taped the mike plug and attached the blue/yellow wire to the corresponding wire on Kenwoods harness.

User avatar
Dara DeGrand
ADS Team
Posts: 5144
Joined: Mon Dec 02, 2013 1:34 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by Dara DeGrand » Wed Apr 11, 2018 8:31 am

That connection is not required- in fact, it might cause weird operation if you leave it hooked up.

Does the light on the RR blink when you press the voice button? If you press and hold it, does the voice command activate? Does it not work under certain conditions (when using carplay, as an example) ?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

mark60
New User
Posts: 8
Joined: Sat Apr 07, 2018 7:53 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by mark60 » Thu Apr 12, 2018 4:04 pm

I won't get to take the dash apart and check it before the weekend but I will update. I started out with the blue plug harness off the unit and only tried it when the voice control didn't react to button press. I was going back over the wiring diagrams and I had everything wired exact as per the DS diagram (no blue plug). I checked other diagrams and saw that on the AS diagram you use the blue plug but no data cable (headunit with no idatalink support) The Kenwod harness has a wire matching the Maestro's and it was labeled steering wheel control so I figured I'd try it. That gave me the voice control button and everything seemed to work correctly. The camera initially didn't shut off even before I plugged in the blue plug so I wouldn't think the extra wire would be causing the camera issue. The camera seems to go off when it feels like it. Sometimes it goes off when shifted out of reverse and randomly it stays in rear view mode.

This is in my wife's Rav4 and I'll be installing the same HU with the Maestro in my '15 Tundra in a week or two so I'm already expecting the same issue given same year Toyota, same HU, and same wiring diagram. If I can get my wife's working well them mine will be easy :)

njhaley1
New User
Posts: 1
Joined: Fri Apr 20, 2018 4:57 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by njhaley1 » Fri Apr 20, 2018 5:01 pm

My troubleshooting has found that it only happens when you don't go into reverse before the head unit boots up. If you put it into reverse before the HU boots up, then it works the remainder of the trip. If you wait until after boot up to go into reverse, you get locked any time you go into reverse for that trip.

I've brought this up with Kenwood. They blame iDatalink, no room for argument. They want me to reset the HU, disconnect the Maestro (I'm not sure I can remove it from the system and have a working HU for what it's worth). I asked iDatalink (Dara), and she says this has been a problem with past Kenwood units.

I tend to believe iDatalink, Kenwood was just too dismissive. I had a JVC unit installed previously, it worked just fine.

Fortunately, I'm in reverse pretty quickly when I start up, so rarely run into the problem.

mark60
New User
Posts: 8
Joined: Sat Apr 07, 2018 7:53 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by mark60 » Sun Apr 22, 2018 9:52 pm

I finally got to pull the dash apart again and the voice command button doesn't initiate any light on the maestro unless the blue plug harness is plugged in.

I played with the backup cam today and got it to lock up once when I put it in reverse before bootup and once after I waited for the HU to boot. I have the same HU waiting for me to install into my truck but now I'm thinking about sending it back and going with Pioneer. I like the HU and like Kenwood headunits in general but I drive too much to be bothered with a cam stuck in reverse. I do lean towards the HU as the issue and not the Maestro.

mark60
New User
Posts: 8
Joined: Sat Apr 07, 2018 7:53 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by mark60 » Sun May 06, 2018 2:59 pm

Alright, need some help to get this working. I was ok with putting the blame on Kenwood but I'm not so sure now.

I had a second 7704 that I was going to put in my 2015 Tundra but after the problems in the Rav4 I returned the second one and exchanged it for a DDX9904s Excelon thinking that maybe the Excelon would play nice. I did the install in my truck last weekend and everything works perfectly.

I returned the 7704 that I had in the Rav4 and replaced it with a 9904 but still have the same camera problems I had before. Something about the Maestro and the Rav4 isn't playing nice together and I'm hoping we can get it figured out. At this point I'm fairly comfortable saying it's not the Headunit but something with the Maestro.

User avatar
Dara DeGrand
ADS Team
Posts: 5144
Joined: Mon Dec 02, 2013 1:34 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by Dara DeGrand » Mon May 07, 2018 10:12 am

Update your RR- we tweaked the firmware, and we believe it should take care of this issue.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

mark60
New User
Posts: 8
Joined: Sat Apr 07, 2018 7:53 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by mark60 » Mon May 07, 2018 12:42 pm

Thank You it's very much appreciated. I'll do this after work this evening and update tonight.

mark60
New User
Posts: 8
Joined: Sat Apr 07, 2018 7:53 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by mark60 » Mon May 07, 2018 8:29 pm

So far it looks promising. I reflashed this evening and put everything back together. It worked perfectly for 6 attempts, 3 before the HU booted up all the way and 3 after it booted fully. So far it looks like a winner. I'll update later in the week and see how it behaves during normal driving conditions.

For now, thank you so much for your help and I'll keep my fingers crossed.

User avatar
Dara DeGrand
ADS Team
Posts: 5144
Joined: Mon Dec 02, 2013 1:34 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by Dara DeGrand » Tue May 08, 2018 8:45 am

Good deal- thank you so much for your patience! If you need anything else, don't hesitate to reach out.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

mark60
New User
Posts: 8
Joined: Sat Apr 07, 2018 7:53 pm

Re: Kenwood DMX7704s Stuck in Rear View

Post by mark60 » Fri May 11, 2018 8:38 pm

Everything is still working perfectly. Thank you so much for hanging in and helping, you folks are great.

Post Reply

Return to “Toyota”