2008 Tundra w/ JBL Nav Installing Pioneer AVH2300NEX

Group using the TO1 and TO2 firmware * see specific firmware for full feature list.
Post Reply
shewards
New User
Posts: 4
Joined: Sun Feb 11, 2018 1:06 pm

2008 Tundra w/ JBL Nav Installing Pioneer AVH2300NEX

Post by shewards » Tue Feb 13, 2018 6:29 pm

I bought the Maestro Rr and the T01 harness. It doesn't appear as though the harness actually fits my truck, as there are a few connections to the truck that are not hooked up and I have some observations:
1) No sound
2) Emergency Break connector isn't connected, so I can't do much with the HU
3) Steering Wheel controls work
4) Vehicle data not connected, get errors and messages to hook it up

Here are some pictures of what's hooked up, and what doesn't have a matching connector:
The whole mess (sideways):
Image

Harness / Maestro connectors without matches:
Image
Image
Image

Truck connectors without matches:
Image
Image
Image

Back of the Pioneer HU:
Image

I haven't tested the backup camera, although I did follow directions to hook that up. Not super high on my priority list at the moment.

I will add this... My JBL unit was fine, then the screen died, but was still playing. I took it out, and took a few minor things apart to see if there were some obvious lose connections, didn't find any and put it back in, and had no sound. Not sure if I did something to damage, say, the amp, when I did all that.

Any help would be appreciated. If you know the boneheaded thing I've done or spot the issue now, I'd love to hear it. Otherwise, I'll call tomorrow morning for support. Mostly just wanted to get the photos on here for the call.

Also, is the Tundra JBL w/ Nav a "network speakers" type system, or "standard"?

-Steve

User avatar
Dara DeGrand
ADS Team
Posts: 4791
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2008 Tundra w/ JBL Nav Installing Pioneer AVH2300NEX

Post by Dara DeGrand » Wed Feb 14, 2018 8:54 am

1) Make sure your blue/white amp turn-on wire is connected between the radio and the TO1 harness. Ensure that the RCAs from the JBL plug are connected to the FL and FR outputs of the pioneer (It looks like yours might be plugged into SW). Make sure that the radio is set to STANDARD mode (not network), and ensure that the white 2-pin data connector on the TO1 is connected (it has light green/red and light green/yellow wires in it).

2&4) Make sure you hook up the light green wire from the RR to the radio, or this will keep popping up. Same thing with the OBD2 plug.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

shewards
New User
Posts: 4
Joined: Sun Feb 11, 2018 1:06 pm

Re: 2008 Tundra w/ JBL Nav Installing Pioneer AVH2300NEX

Post by shewards » Wed Feb 14, 2018 1:11 pm

Thanks, Dara.

1) Blue/ white is connected. There are no RCA ports on the JBL, but there are on the Pioneer. Instructions say to "connect to LF and RF low level outputs", the Pioneer has "FL and FR" outputs, and I misinterpreted the instructions as to mean "low range". I'm sure you're right and have corrected that issue. THANKS!

2) The light green from the T01 is connected to light green from the radio.

Which is the OBD2 plug? Do you see it pictured above? I really suspect I'm missing a connector somewhere.

Thanks again,
-Steve
Dara DeGrand wrote:
Wed Feb 14, 2018 8:54 am
1) Make sure your blue/white amp turn-on wire is connected between the radio and the TO1 harness. Ensure that the RCAs from the JBL plug are connected to the FL and FR outputs of the pioneer (It looks like yours might be plugged into SW). Make sure that the radio is set to STANDARD mode (not network), and ensure that the white 2-pin data connector on the TO1 is connected (it has light green/red and light green/yellow wires in it).

2&4) Make sure you hook up the light green wire from the RR to the radio, or this will keep popping up. Same thing with the OBD2 plug.

shewards
New User
Posts: 4
Joined: Sun Feb 11, 2018 1:06 pm

Re: 2008 Tundra w/ JBL Nav Installing Pioneer AVH2300NEX

Post by shewards » Wed Feb 14, 2018 1:28 pm

Changed the RCA over to the front speaker ports and now I have crisp clear super high treble in all speakers. PROGRESS! I'm sure that would be fixed if I could get the emergency break lock disabled, or get that connection made.

Backup camera does not work. Followed instructions, and cut / spliced the wires from the connector in picture 5.

Calling support now.

shewards
New User
Posts: 4
Joined: Sun Feb 11, 2018 1:06 pm

Re: 2008 Tundra w/ JBL Nav Installing Pioneer AVH2300NEX

Post by shewards » Thu Feb 15, 2018 4:08 pm

Some notes after all is good...

1) iDatalink support staff are GREAT. Justin really helped a lot, and I talked with another person after that with some follow-up questions that also helped. I didn't get his name.
2) The diagram for installation is not clear (if you're unfamiliar with vehicle systems) that you have to plug in something to that data port near your steering column (that thing Flo from Progressive wants you to use to track your driving habits). That's the OBD2 port. The long cable with sheathing goes to that.
3) The "off hook" button (used to initiate a call) on the steering wheel doesn't work on some (all?) Pioneer head units. Nothing iDatalink can do about it. Also, this connection is required for the backup camera to be engaged (and you have to turn it on in the Pioneer setup menu).
4) OEM Tundra systems do not use "network speakers", and you use the FL and FR RCA ports on the Pioneer.
5) You can't use the OEM microphone with aftermarket head units.

I used an undone wire hanger to grab the OBD2 and microphone cables from under the driver's dash to pull them up behind the head unit.

Hope this helps others, and thanks again to iDatalink support.
-Steve

Post Reply

Return to “Toyota”