2010 Jeep Commander park assist

Post Reply
KaeZoo
12Volt Specialist
Posts: 17
Joined: Wed Nov 14, 2012 5:08 pm

2010 Jeep Commander park assist

Post by KaeZoo » Sun Oct 02, 2016 7:45 pm

I installed a Kenwood DDX09702S into this vehicle; all features seem to be working except Park Assist. The option is grayed out on the screen.

The original radio was RES with a phone button, but the vehicle did not have U-connect (pressing the button showed "U-connect not equipped" on the display). The smaller plug in the CH1 harness had no connection behind the factory head unit. There was a second plug at the head unit, same size as the main plug, with three wires in it.

Anything I can do to help the Maestro find the Park Assist system?
Brian Neathery
Best Buy #409
3410 Alpine Avenue
Walker, MI 49534
(616) 785-6740

User avatar
Dara DeGrand
ADS Team
Posts: 3615
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2010 Jeep Commander park assist

Post by Dara DeGrand » Mon Oct 03, 2016 3:29 pm

Does the parking assist show up in the vehicle's EVIC display?
Dara DeGrand Technical/Product Support Specialist
Automotive Data Solutions Inc.
8400 bougainville, QC
T 514.807.2888
TF 866.427.2999

KaeZoo
12Volt Specialist
Posts: 17
Joined: Wed Nov 14, 2012 5:08 pm

Re: 2010 Jeep Commander park assist

Post by KaeZoo » Wed Oct 05, 2016 9:49 am

Short answer: I don't know. I didn't notice it, but didn't think to look for it. It does have the LED display over the rear hatch.
Brian Neathery
Best Buy #409
3410 Alpine Avenue
Walker, MI 49534
(616) 785-6740

KaeZoo
12Volt Specialist
Posts: 17
Joined: Wed Nov 14, 2012 5:08 pm

Re: 2010 Jeep Commander park assist

Post by KaeZoo » Fri Oct 07, 2016 6:56 pm

Talking with the customer, he tells me that there is no park assist message on the EVIC; the only indicator is the rear light bar.
Brian Neathery
Best Buy #409
3410 Alpine Avenue
Walker, MI 49534
(616) 785-6740

User avatar
Dara DeGrand
ADS Team
Posts: 3615
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2010 Jeep Commander park assist

Post by Dara DeGrand » Mon Oct 10, 2016 8:47 am

That could definitely be why; if there is no message on the EVIC, the RR is likely unable to detect the parking assist.
Dara DeGrand Technical/Product Support Specialist
Automotive Data Solutions Inc.
8400 bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “CH1 radio replacement solution”