Steering wheel Controls stopped working and weird bug

Post Reply
YukonGuy
New User
Posts: 4
Joined: Wed Mar 02, 2016 1:11 am

Steering wheel Controls stopped working and weird bug

Post by YukonGuy » Mon Jan 30, 2017 4:31 pm

Hi guys, I currently have the Maestro RR GM5+ with a Pioneer 4100nex installed in my 2009 Gmc Yukon

For about 5 months I previously had the radio working great and a few occasional bugs but nothing too bad.After I recently finished installing my new audio setup the radio is producing an error.The steering wheel controls are completely dead, on a rare occurrence, for 30 seconds the radio the controls work about once.Also when i press any button on the radio it takes me to the Bluetooth menu.So for example turning the volume up it always opens the Bluetooth menu.I did install a micro bypass but nothing has come up for this issue.The maestro also lights up green when pressing a button on the wheel.Ive come to conclusion that it most likely is the maestro module itself,as I have checked all connections and in the radio the module has OK status.Any help would be great,Thanks!

User avatar
Dara DeGrand
ADS Team
Posts: 4551
Joined: Mon Dec 02, 2013 1:34 pm

Re: Steering wheel Controls stopped working and weird bug

Post by Dara DeGrand » Mon Jan 30, 2017 5:00 pm

Is there anything plugged into the W/R on the radio?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “GM5+ radio replacement solution”