2006 Audi A4 B7 - No data/No Gauges

Group using the VW1 firmware for Media Device Interface (MDI), Multi-Funtion Display (MFD), bluetooth, amplifier turn on, amplifier digital fader, amplifier gain adjustment, steering wheel control, custom gauges, vehicle info, park assist, Navigation arrows on MFD, climate status screen...
AudiB713
New User
Posts: 9
Joined: Fri Feb 16, 2018 12:32 am

2006 Audi A4 B7 - No data/No Gauges

Post by AudiB713 » Fri Feb 16, 2018 10:45 am

Hoping someone can help me figure out where I've gone wrong.

I currently have a JVC 730 headunit with a maestro rr. Everything looks to be working like it should. Steering wheel controls work. I just can't seem to get the gauges to receive any data and also the check engine light on the dash doesn't show on screen of the car info page.

Wondering if anyone had any suggestions. You're help is greatly appreciated!

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by Dara DeGrand » Fri Feb 16, 2018 10:52 am

Did you hook up the two wires at the OBD2?

Is there an error on the gauges screen? OBD2 disabled, or OBD2 disconnected, as an example.

Do you have an active check engine light? If not, the CEL on the Vehicle Info screen should be gray. When you have an active diagnostic trouble code, the engine icon will light up orange.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

AudiB713
New User
Posts: 9
Joined: Fri Feb 16, 2018 12:32 am

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by AudiB713 » Fri Feb 16, 2018 2:08 pm

Yes the harness came with a obd2 connector that plugs directly into the car plug. There's no "disconnect" error or messages that come up. I tried all the different settings for the obd2 (i.e. Always enabled, disabled, etc) nothing seemed to change it.

I do have a check engine light on. So that's not showing up. I'm not sure if the CAN wires are somehow switched on the harness. Running out of ideas.

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by Dara DeGrand » Fri Feb 16, 2018 2:37 pm

There should be an error message if it sees no communication from the OBD2. Can you snap a picture of the gauges screen and post it here?

Have you tried resetting the RR (in the radio settings, under OEM Setup > Maestro module) ?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

AudiB713
New User
Posts: 9
Joined: Fri Feb 16, 2018 12:32 am

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by AudiB713 » Fri Feb 16, 2018 3:22 pm

https://ibb.co/e91LLn

Here's a link to the photo. I'm not great at posting things. I apologize for my novice abilities here. :?

Sorry about the glare. I did reset the module. Still didn't do the trick. Wondering if I need to update the firmware of the radio itself.

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by Dara DeGrand » Fri Feb 16, 2018 3:43 pm

Thanks for the picture! I don't think it's a radio firmware thing; it might be a communication issue with the vehicle; i'm looking into it with our engineering team.

In the OEM setup menu, you should be able to go into maestro features > gauges > about gauges. What does that screen show?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

AudiB713
New User
Posts: 9
Joined: Fri Feb 16, 2018 12:32 am

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by AudiB713 » Sat Feb 17, 2018 11:26 am

Settings -> AV -> OEM Setup -> Vehicle Features ->

There's four options that are not grayed out.
1. Gauges
2. Vehicle Info Settings
3. Cluster Info Display
4. Clear airbag indicator

Clicking on gauges.
1. Select gauges
2. Gauges global unit
3. Fuel economy
4. Validate PIDs
5. OBD2 Communication
6. Center Gauge Warning

AudiB713
New User
Posts: 9
Joined: Fri Feb 16, 2018 12:32 am

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by AudiB713 » Sun Feb 18, 2018 12:49 pm

Forgot to mention "about gauges" is greyed out

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by Dara DeGrand » Mon Feb 19, 2018 9:31 am

This means that we're seeing the vehicle's ignition as 'off'. This would explain why the gauges aren't working, too. We're still digging into it, because if we see the ignition as off, you should at least be getting an error message on the gauges screen.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

AudiB713
New User
Posts: 9
Joined: Fri Feb 16, 2018 12:32 am

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by AudiB713 » Sat Feb 24, 2018 12:47 am

Could this be a wiring issue?

Just seeing if there's any ideas.

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by Dara DeGrand » Mon Feb 26, 2018 8:43 am

It's not likely that it's a wiring issue. All of these things are sensed on the data lines in the vehicle. If we're not seeing the messages that we normally look for, that would cause the odd behavior.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

AudiB713
New User
Posts: 9
Joined: Fri Feb 16, 2018 12:32 am

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by AudiB713 » Mon Feb 26, 2018 10:36 am

After double checking the installation that was made.
The VSS and foot brake wires are not connected on my HU.
Also the ground is not grounded to the frame.

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by Dara DeGrand » Mon Feb 26, 2018 10:37 am

Okay? Those wires shouldn't have anything to do with this issue.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

AudiB713
New User
Posts: 9
Joined: Fri Feb 16, 2018 12:32 am

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by AudiB713 » Mon Feb 26, 2018 10:41 am

I realize that. I am just hitting my head against the wall trying to wait for a solution.
But I guess I will bite my tongue, and wait to hear for a solution.

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2006 Audi A4 B7 - No data/No Gauges

Post by Dara DeGrand » Mon Mar 05, 2018 12:13 pm

Just wanted to update you- i have a test firmware for you to try, and i have sent it to your account.

To get it, log in, hit "flash your module" and select the "flash by user firmware" tab. There will be a firmware in there called "ADS-RR(SR)-AUD01-DS (512) 1.7". Select it, proceed with the flash, and give it a try. Please let me know how it works out for you.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “Volkswagen”