2008 GMC Sierra SLT w/standard bose

Group using the GM3 and GM5 firmware for Onstar bluetooth, sat radio, Door chime, turn signal retention and steering wheel control, custom gauges, vehicle info, park assist... * see specific firmware for full feature list.
Post Reply
nickmandrews1988
New User
Posts: 1
Joined: Thu May 17, 2018 1:07 pm

2008 GMC Sierra SLT w/standard bose

Post by nickmandrews1988 » Thu May 17, 2018 1:21 pm

i recently purchased a Kenwood DDX395 with the maestro rr and the required GM5+. I had Crutchfield wire the t-harness. upon instillation ive encountered an issue which no one seems to be able to give me assistance with. I have no sound. The factory functions i wanted to preserve work. I can get reception of xm channels, my steering wheel controls work, and the chime from the GM5 speaker works. The stereo powers u[ but no sound from the speakers. I've repeatedly gone over the wiring with Crutchfield tech support and everything is where its supposed to be. When I called idatalink i was told the maestro didn't flash completely on the back end, although the webpage told me complete. This occurred on three separate occasions. Is that the reason for no sound? What can i do to get it to flash completely? Could the harness be wired for Premium bose and I have standard? Help please.

User avatar
Dara DeGrand
ADS Team
Posts: 5135
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2008 GMC Sierra SLT w/standard bose

Post by Dara DeGrand » Thu May 17, 2018 2:10 pm

There is no difference between the premium and standard bose wiring. If you have access to a multi-meter, we should check the amp turn-on voltage, both from the radio, and where it exits the maestro (the blue/yellow wire on the green plug of the RR).
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “Chevrolet, GMC, Buick, Cadillac, Pontiac, Saturn, Hummer”