Need help getting things setup

Group using the GM3 and GM5 firmware for Onstar bluetooth, sat radio, Door chime, turn signal retention and steering wheel control, custom gauges, vehicle info, park assist... * see specific firmware for full feature list.
scottnj1966
New User
Posts: 17
Joined: Sun Nov 26, 2017 1:28 am

Need help getting things setup

Post by scottnj1966 » Sun Nov 26, 2017 3:32 pm

I have a 2013 Chevrolet Avalanche. It has the oem navigation system, bose, xm, and onstar.
I am installing a Kenwood 9702s
I have the Maestro ADS-RR and the GM2 kit

I have most of everything attached and working except for a few things.

First, what are the two mini audio plugs for that come from the ads-rr? One actually has a wire attached to it. Where should they connect? or do I not use these for my application?

How do I use onstar? I don't even see a place where to plus the antenna in. I cannot get it to hear my voice.

Microphone does not hear my voice for carplay unless I plug in the kenwood mic. With all these adapters and such do I really have to use the aftermarket mic?

I did not get a usb adapter to retain the oem usb port. Did they short me or is it really not included?

Will this system not allow for my factory dynamic lines for the backup camera?
Is that a limitation of the stereo?

User avatar
Dara DeGrand
ADS Team
Posts: 4409
Joined: Mon Dec 02, 2013 1:34 pm

Re: Need help getting things setup

Post by Dara DeGrand » Mon Nov 27, 2017 7:39 am

You will not use the blue plug on the maestro. The other audio cable (all black, 3-pin to 3.5mm cable) should go from the maestro to the "iDatalink I/F" connector on the kenwood. If you don't have that plugged in, your onstar won't work 100%.

The USB adapter is not included.

You MUST use the Kenwood mic for CarPlay. It is a kenwood feature, so the radio is looking on its own mic input when you activate CarPlay. There is no way to mix and match components from two separate bluetooth systems, so you must use the mic provided with the Kenwood.

I need to do a little research on the dynamic guidelines- I don't believe dynamic guidelines were supported with that radio model, but I will make sure and update my post when I know for sure.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

scottnj1966
New User
Posts: 17
Joined: Sun Nov 26, 2017 1:28 am

Re: Need help getting things setup

Post by scottnj1966 » Mon Nov 27, 2017 2:54 pm

Thank you for the quick reply.

I decided to buy a multi port that has usb and hdmi so I will not be utilizing the oem wire now.

Its a disappointment not being able to use the built in mic. The mic that comes with the kenwood system isn't very good.

I thought I read on the instructions for my truck that the dynamic lines would work, I thought that is why I keyed in that model kenwood when flashing the firmware. My guess is that it does not work. I was hoping the ac controls would also show but they do not.

Do you happen to know what model kenwood would allow those two features to work?

I have a few more adapters and such to finish up this project. I may have more questions.


Thanks again for the help

Scott

scottnj1966
New User
Posts: 17
Joined: Sun Nov 26, 2017 1:28 am

Re: Need help getting things setup

Post by scottnj1966 » Mon Nov 27, 2017 2:57 pm

The oem navigation system had three antenna leads. Were those for the radio, gps, and xm? OnStar separate?

User avatar
Dara DeGrand
ADS Team
Posts: 4409
Joined: Mon Dec 02, 2013 1:34 pm

Re: Need help getting things setup

Post by Dara DeGrand » Mon Nov 27, 2017 3:01 pm

Last year's models and newer will support dynamic guidelines (example: DNX893S, DDX9703s, etc).

Yes, that is correct- Satellite, GPS, and FM radio.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

scottnj1966
New User
Posts: 17
Joined: Sun Nov 26, 2017 1:28 am

Re: Need help getting things setup

Post by scottnj1966 » Wed Nov 29, 2017 10:03 am

I've decided to upgrade from the ddx9702 to the ddx9704

This will get me a clearer screen that the touch will respond better.
It will also get me the dynamic back up lines.
Could you tell me if it will enable any other features? like the ac controls and such?


Thank you

Scott

User avatar
Dara DeGrand
ADS Team
Posts: 4409
Joined: Mon Dec 02, 2013 1:34 pm

Re: Need help getting things setup

Post by Dara DeGrand » Wed Nov 29, 2017 10:29 am

Changing radios will not enable any other features. The iDatalink features you get will be the exact same from one Kenwood to another.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

scottnj1966
New User
Posts: 17
Joined: Sun Nov 26, 2017 1:28 am

Re: Need help getting things setup

Post by scottnj1966 » Wed Nov 29, 2017 5:15 pm

That’s not what you told me before. You said that the newer models would allow the dynamic lines to work and that my model stereo that I have now didn’t have that feature.

What dictates what features work and does not work. The car manufacturer, stereo manufacturer, or Maestro?

User avatar
Dara DeGrand
ADS Team
Posts: 4409
Joined: Mon Dec 02, 2013 1:34 pm

Re: Need help getting things setup

Post by Dara DeGrand » Wed Nov 29, 2017 5:23 pm

Ok, correction. The ONE thing you will gain is dynamic guidelines. Sorry for the confusion.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

scottnj1966
New User
Posts: 17
Joined: Sun Nov 26, 2017 1:28 am

Re: Need help getting things setup

Post by scottnj1966 » Wed Nov 29, 2017 10:06 pm

Would I have access to the rear camera beyond backing the vehicle up?

User avatar
Dara DeGrand
ADS Team
Posts: 4409
Joined: Mon Dec 02, 2013 1:34 pm

Re: Need help getting things setup

Post by Dara DeGrand » Thu Nov 30, 2017 7:46 am

The vehicle is what powers the camera- In GM, I believe it is only powered when you're in reverse.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

scottnj1966
New User
Posts: 17
Joined: Sun Nov 26, 2017 1:28 am

Re: Need help getting things setup

Post by scottnj1966 » Thu Nov 30, 2017 2:45 pm

Dara DeGrand wrote:
Thu Nov 30, 2017 7:46 am
The vehicle is what powers the camera- In GM, I believe it is only powered when you're in reverse.
I was afraid of that.

Thanks

Scott

scottnj1966
New User
Posts: 17
Joined: Sun Nov 26, 2017 1:28 am

Re: Need help getting things setup

Post by scottnj1966 » Fri Dec 08, 2017 1:34 am

scottnj1966 wrote:
Wed Nov 29, 2017 10:06 pm
Would I have access to the rear camera beyond backing the vehicle up?

Hello,

The Kenwood 9704 is now installed. Onstar worked great with your help on the connections.
I have a questions about the dynamic lines. They do look quite right. It looks like the stationary lines are on top of the dynamic lines. Is this correct?

User avatar
Dara DeGrand
ADS Team
Posts: 4409
Joined: Mon Dec 02, 2013 1:34 pm

Re: Need help getting things setup

Post by Dara DeGrand » Fri Dec 08, 2017 8:33 am

I believe you can change that in the Kenwood backup camera settings.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

scottnj1966
New User
Posts: 17
Joined: Sun Nov 26, 2017 1:28 am

Re: Need help getting things setup

Post by scottnj1966 » Mon Dec 11, 2017 11:34 pm

Dara DeGrand wrote:
Fri Dec 08, 2017 8:33 am
I believe you can change that in the Kenwood backup camera settings.
I think the kenwood lines are on top of the maestro lines. I think I tried turning off the kenwood lines but then it them all off. I’ll try once again to verify.

Thank you.

Post Reply

Return to “Chevrolet, GMC, Buick, Cadillac, Pontiac, Saturn, Hummer”