2013 F150 - Kenwood DNX994 - Maestro - Cel signal static

Group using the FO1 and FO2 firmware for Ford SYNC retention * see specific firmware for full feature list.
Post Reply
don.miller
New User
Posts: 2
Joined: Mon Apr 30, 2018 11:36 am

2013 F150 - Kenwood DNX994 - Maestro - Cel signal static

Post by don.miller » Mon Apr 30, 2018 11:49 am

Very weird issue: Went to the mountains this weekend, when no Cel signal available, I get a back feed noise through the speakers. I tested this over a 6 mile stretch of road as follows. Drove to a spot where I can get a cel signal (Verizon 4g LTE 2 bars strength), no sound. Pull away from area around corner and as soon as hill blocks signal, sound from speakers starts. Stereo is on showing GPS screen. Iphone not attached to USB port. Back up to spot where I can get cel signal, sound stops. Thoughts?

Setup: Kenwood DNX994 brand new. Had a Kenwood DNX893 that died and Crutchfield replaced with the 994. I have SYNC turned off in the Maestro. NO cable hooked to the little 3mm outlet on the maestro. System has been installed since Feb 2, 2018.

It I plug in iphone to the USB and stream music, it covers the sound but it was very annoying. I want to use my GPS and not here the whining sound. If the head unit is turned off, sound of course goes away.

Not a ground issue as the music, phone sound is crystal clear when I have a cel signal available.

Pulling my hair out.

Don Miller

User avatar
Dara DeGrand
ADS Team
Posts: 5022
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2013 F150 - Kenwood DNX994 - Maestro - Cel signal static

Post by Dara DeGrand » Mon Apr 30, 2018 4:58 pm

If you're getting noise through the Kenwood bluetooth, this is a Kenwood issue. We don't control the audio coming out of the source unit, especially the bluetooth source that is contained within the radio.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

don.miller
New User
Posts: 2
Joined: Mon Apr 30, 2018 11:36 am

Re: 2013 F150 - Kenwood DNX994 - Maestro - Cel signal static

Post by don.miller » Tue May 01, 2018 1:57 pm

Thanks Dara. I was unsure if the Maestro had any cellular input due the interacting with the Sync. I will contact Kenwood.

Don Miller

Post Reply

Return to “Ford, Lincoln, Mercury, Mazda”