2009 Escape Hybrid Issues

Group using the FO1 and FO2 firmware for Ford SYNC retention * see specific firmware for full feature list.
n6mon
New User
Posts: 22
Joined: Sat Mar 31, 2018 11:01 pm

2009 Escape Hybrid Issues

Post by n6mon » Sat Mar 31, 2018 11:07 pm

I have a 2009 Ford Escape Hybrid (no factory nav). Using a Kenwood DNX893S and an RR interface.

First issue, the volume, media and track/station buttons work fine, but the Sync buttons do not.

The second issue is with the "satellite radio" mode. When I choose satellite radio on the radio, I get audio for about 5 seconds (the length of time that the date/time displays on the information display) and then the audio cuts off and I cannot perform any functions on the radio screen.

BOTH of these were working fine with the factory radio.

User avatar
Dara DeGrand
ADS Team
Posts: 5205
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2009 Escape Hybrid Issues

Post by Dara DeGrand » Mon Apr 02, 2018 9:39 am

Does the light on the RR flash when you press voice or phone on your steering wheel?

Also, re-flash your RR. We did some updates at the end of last week that turned out to be slightly broken- if you update your RR, i think your satellite issue will be resolved.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

n6mon
New User
Posts: 22
Joined: Sat Mar 31, 2018 11:01 pm

Re: 2009 Escape Hybrid Issues

Post by n6mon » Mon Apr 02, 2018 10:26 am

1) Where is the light on the RR?
2) I re-flashed yesterday with no change.

User avatar
Dara DeGrand
ADS Team
Posts: 5205
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2009 Escape Hybrid Issues

Post by Dara DeGrand » Mon Apr 02, 2018 10:56 am

1) It's a little clear window, right by the button on the RR.
2) We didn't fix the firmware until this morning, so a re-flash yesterday wouldn't have fixed it.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

n6mon
New User
Posts: 22
Joined: Sat Mar 31, 2018 11:01 pm

Re: 2009 Escape Hybrid Issues

Post by n6mon » Mon Apr 02, 2018 2:44 pm

I spoke to someone on the phone earlier. Factory satellite radio is now working. Sync responds to the steering wheel buttons, but I cannot get into the Sync setup to pair a phone. This CANNOT be done by voice prompts, only from the display. I choose "Tel" from the inputs menu, it shows Sync, there is a gear icon next to the phone, which I PRESUME would bring up the Sync pairing screen, but it just turns blue with no action. I have confirmed that parking brake control works (I can play a DVD with the parking brake on, but not with it off).

You also have an issue with the factory information display when using Sync, but I cannot attach a picture, si I need to know where to send that photo.

I would REALLY like to get these issues fixed today so that I can button up this installation.

User avatar
Dara DeGrand
ADS Team
Posts: 5205
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2009 Escape Hybrid Issues

Post by Dara DeGrand » Mon Apr 02, 2018 3:10 pm

I know- I also got your email. When you use the forums, email, phone, etc, you are talking to the same team of three people. We're working to get you resolved, but by and large, these issues are always easier to fix over the phone when you're in the car.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

n6mon
New User
Posts: 22
Joined: Sat Mar 31, 2018 11:01 pm

Re: 2009 Escape Hybrid Issues

Post by n6mon » Mon Apr 02, 2018 6:04 pm

One additional item, when programming and setting the buttons, I cannot change the voice button and the defaults set are different.

The programming page indicates:

Button Press Press and hold
Voice Sync Media Voice Prompt Sync Phone Voice Prompt

but a momentary press, which SHOULD bring up the Sync Media Voice Prompt changes the source to Sync Bluetooth. Press and hold brings up the Voice Prompt.

n6mon
New User
Posts: 22
Joined: Sat Mar 31, 2018 11:01 pm

Re: 2009 Escape Hybrid Issues

Post by n6mon » Tue Apr 03, 2018 5:16 pm

One additional issue for you:

On the satellite radio screen (for the Ford factory sat radio), there are are two buttons, up arrow and down arrow. I would presume that those would either step up and/or down on the memories or the channel list. They done neither. For a while, if I pressed one of them, it would go to channel 120, but after I locked that out, they do nothing.

The top of the display briefly shows "seek " when a button is pushed, but after that, nothing.

User avatar
Dara DeGrand
ADS Team
Posts: 5205
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2009 Escape Hybrid Issues

Post by Dara DeGrand » Wed Apr 04, 2018 9:40 am

n6mon wrote:
Tue Apr 03, 2018 5:16 pm
One additional issue for you:

On the satellite radio screen (for the Ford factory sat radio), there are are two buttons, up arrow and down arrow. I would presume that those would either step up and/or down on the memories or the channel list. They done neither. For a while, if I pressed one of them, it would go to channel 120, but after I locked that out, they do nothing.

The top of the display briefly shows "seek " when a button is pushed, but after that, nothing.
Does the screen look the same when you're on FM stereo (in terms of the up/down arrow) ? If so those are your presets. What do you mean when you say you 'locked them out' ?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

n6mon
New User
Posts: 22
Joined: Sat Mar 31, 2018 11:01 pm

Re: 2009 Escape Hybrid Issues

Post by n6mon » Wed Apr 04, 2018 3:56 pm

On the normal radio side, the up/down buttons mirror the steering wheel seek buttons, which do a 'next station' seek.

User avatar
Dara DeGrand
ADS Team
Posts: 5205
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2009 Escape Hybrid Issues

Post by Dara DeGrand » Wed Apr 04, 2018 7:41 pm

Okay.. So what do you mean when you say that you "locked them out". I'm still not following. Perhaps you could send us a video?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

n6mon
New User
Posts: 22
Joined: Sat Mar 31, 2018 11:01 pm

Re: 2009 Escape Hybrid Issues

Post by n6mon » Thu Apr 05, 2018 6:18 pm

Link to video sent in eMail

User avatar
Dara DeGrand
ADS Team
Posts: 5205
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2009 Escape Hybrid Issues

Post by Dara DeGrand » Wed Apr 11, 2018 8:29 am

If you update your RR, the engineer believes it should fix the issue with your display looking strange. We had a firmware bug that affected some other things, too. It was fixed yesterday in version 3.3.
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

n6mon
New User
Posts: 22
Joined: Sat Mar 31, 2018 11:01 pm

Re: 2009 Escape Hybrid Issues

Post by n6mon » Tue May 01, 2018 3:59 pm

Well, good news and bad news.

The update fixed the issue with the factory satellite receiver stepping through channels.

You created a NEW problem. If I use Sync to voice dial a phone number, it dials and THINKS it is connected to Sybnc Bluetooth audio, but it is NOT. If I dial from the phone keypad or radio display, it works fine. This was ALL working properly before I put the update on today.

User avatar
Dara DeGrand
ADS Team
Posts: 5205
Joined: Mon Dec 02, 2013 1:34 pm

Re: 2009 Escape Hybrid Issues

Post by Dara DeGrand » Tue May 01, 2018 4:35 pm

Can you elaborate? When you voice dial, does the call go to the phone handset, or does sync connect the call and there's just no audio?
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

Post Reply

Return to “Ford, Lincoln, Mercury, Mazda”